Dec 21 2009

64位的Linux中运行32位的应用程序

Category: 技术ssmax @ 15:22:44

    大部分Linux发行套件都有针对x86_64处理器的版本。比较典型的x86_64的处理器有ADM Athlon II和英特尔Xeon。因为这些Linux发行套件都有自己专用的软件源,这些软件源会为提供所有它所支持的应用软件的二进制包。如果你满足于Linux的安装方式,你可能不会需要运行32位的程序。

    一些Linux商业软件,尤其是游戏,只提供32的版本。因为某些特殊的理由,你可能需要配置你的电脑来运行32位的软件。

    而在64位linux下运行这些32位系统的时候,经常会出现:

    No such file or directory 错误。

    只需要安装32位的支持库,就可以解决以上问题。

    因为x86_64处理器是为x86技术涉及,所以它也是支持32位程序的。在Linux里,你所需要做的就是为这些软件安装必要的软件库。幸运的是,大部分Linux发行版本已经将这些打包好了。比方在Ubuntu/debian里,这个包就叫做ia32-libs。为了安装它,你可以打开一个终端,然后输入下面的内容:

    sudo apt-get install ia32-libs

Leave a Reply